Kicad

Iš OeeTechWiki.
Jump to navigation Jump to search

Turinys

KiCad naudojimosi vadovas

KiCad projekto paruošimas

  1. Atsisiųsti ir įdiegti KiCad: https://kicad-pcb.org/download/
  2. Sukurti naują projektą (CTRL+N arba File → New → Project...):

2020 12 07 OeeTechWiki kiCad 1pav.png 2020 12 07 OeeTechWiki kiCad 2pav.png


Sukūrus projektą, Kicad langas turėtų atrodyti taip:

2020 12 07 OeeTechWiki kiCad 3pav.png

Schemos braižymo pagrindai

Schemos navigacija

Priartinimas (MOUSEWHEEL)

Vertikalus judėjimas (SHIFT+MOUSEWHEEL)

Horizontalus judėjimas (CTRL+MOUSEWHEEL)

Veiksmai su komponentų simboliais

Simbolio įdėjimas (A – komponentai, P – maitinimo simboliai)

2020 12 07 OeeTechWiki kiCad 4pav.png 2020 12 07 OeeTechWiki kiCad 5pav.png

Pasirinkus simbolį, jį reikia nuvesti į norimą vietą, jei reikia, pasukti (R), apversti pagal norimą

ašį (X/Y) ir padėti ant schemos su kairiuoju pelės mygtuku.

Simbolio pasukimas (R)

Simbolio apvertimas pagal X ašį (X)

Simbolio apvertimas pagal Y ašį (Y)

2020 12 07 OeeTechWiki kiCad 6pav.png 2020 12 07 OeeTechWiki kiCad 7pav.png


Šiuos veiksmus galima atlikti ne tik dedant simbolį, bet ir jau padėjus simbolį. Tereikia užvesti kursorių ant simbolio ir paspausti vieną iš klavišų.

Simbolio judinimas (M)

Norint pajudinti jau padėta simbolį, galima ant jo paspausti (M). Tokiu būdu judinamas simbolis bus atjungtas nuo betkokių jungčių. Norint to išvengti, simbolį taip pat galima judinti paspaudus (G).

Tinklelio nustatymai (Grid)

Norint pakeisti tinklelio, prie kurio komponentų simboliai „užsifiksuoja“, galima bet kur ant schemos (kad ir ant komponento) paspausti dešinįjį pelės mygtuką ir atsidariusiame lange nueiti į Grid ir ten pasirinkti norimą tinklelio dydį.

2020 12 07 OeeTechWiki kiCad 8pav.png

Simbolio parametrų redagavimas (E)

704

Simbolio kopijavimas (C)

Prieš pradedant dėlioti komponentus, patartina susikurti dažnai naudojamų komponentų (pvz rezistorių) šablonus ir pilnai aprašyti jų parametrus (pvz. value, tiekėjas, footprint’as ir pnš.). Pasidarius tokius šablonus galima juos kopijuoti ir taip sutaupyti daug laiko.

2020 12 07 OeeTechWiki kiCad 10pav.png

Norint kopijuoti simbolį, reikia ant simbolio užvesti kursorių, paspausti (C). Tada galima atlikti jau ankščiau minėtus veiksmus.

Simbolių jungimas

Norint sujungti komponentus, galima naudoti laidus, etiketes (label), šynas (bus) arba jungti tiesiogiai prie kitų komponentų išėjimų.

Jungimas laidais (W)

Norint naudoti laidus, reikia ant norimo komponento išėjimo užvesti kursorių ir paspausti (W). Tada su pele, nuvesti laidą į kito komponento išėjimą ir paspausti kairįjį pelės mygtuką.

Kampo sukurimas, laido vedimo metu (Z)

Vedant laidą galima sukurti kampą paspaudus (Z) ir toliau vedant laidą į norimą pusę.

Laido nutraukimas, laido vedimo metu (K)

Norint palikti atvirą jungtį, laido vedimo metu galima paspausti (K) arba du kartus paspausti kairįjį pelės mygtuką.

Simbolių tempimas su laidais (G)

Simbolius galima judinti kartu su laidais, bei tiesiogiai prijungtais komponentais, paspaudus ant jų (G). Tačiau ši funkcija gali suteikti nelauktų rezultatų, jei ji būna netinkamai panaudota. Ši funkcija taip pat leidžia pailginti laidus.

2020 12 07 OeeTechWiki kiCad 11pav.png2020 12 07 OeeTechWiki kiCad 59pav.png 2020 12 07 OeeTechWiki kiCad 12pav.png2020 12 07 OeeTechWiki kiCad 60pav.png

2020 12 07 OeeTechWiki kiCad 13pav.png2020 12 07 OeeTechWiki kiCad 58pav.png2020 12 07 OeeTechWiki kiCad 14pav.png2020 12 07 OeeTechWiki kiCad 61pav.png

Patogus laidų prie IC jungimo būdas (INSERT)

Ši funkcija veikia ne tik su laidais, bet ir komponentais. Pratiesus horizontalų laidą prie IC išėjimo, paspaudus (INS) klavišą, po sukurtu laidu bus sukurtas tokio paties ilgio laidas. Taip, keliais (INS) klavišo paspaudimais, galima greitai sukurti jungtis prie kiekvieno IC išėjimo.

2020 12 07 OeeTechWiki kiCad 15pav.png2020 12 07 OeeTechWiki kiCad 59pav.png2020 12 07 OeeTechWiki kiCad 16pav.png

Nenaudojamos jungties ženklas (Q)

Tam, kad KiCad žinotų, jog tam tikros komponento jungtys nebus naudojamos, ant jungčių reikia uždėti tą parodantį ženklą, ant jų paspaudus (Q) klavišą.

Etikečių naudojimas (L)

Etiketės (label) leidžia sujungti komponentus be laidų. Dvi ar daugiau etiketės, turinčios tokį pat pavadinimą sukuria jungtis tarp komponentų išėjimų, ant kurių tos etiketės yra uždėtos. Dedant etiketes galima naudoti (INS) mygtuką ir taip bus automatiškai sudėtos ir sunumeruotos etiketės.

2020 12 07 OeeTechWiki kiCad 17pav.png2020 12 07 OeeTechWiki kiCad 62pav.png2020 12 07 OeeTechWiki kiCad 18pav.png

Šios dvi schemos atlieką lygiai tą pačią funkciją. Vienintelis skirtumas yra tas, jog dešinioji schema yra lengviau sujungiama ir atrodo aiškiau.

Šynų naudojimas (B)

Šynos (bus) leidžia vaizdžiai sujungti norimo tipo (pvz duomenų) išėjimus. Šynos naudojamos kartu su etiketėmis. Ant šynos reikia uždėti etiketę tokiu formatu:

Pavadinimas[pirmas_skaitmuo..paskutinis_skaitmuo]

Norint pereiti iš šynos į laidą ir atvirkščiai, reikia naudotis dešinėje pusėje esančius mygtukus.

2020 12 07 OeeTechWiki kiCad 20pav.png 2020 12 07 OeeTechWiki kiCad 19pav.png

Perėjimas iš schematikos į PCB dizainą

Prieš pereinant į PCB dizainą, pirma reikia sugeneruoti anotacijas (sunumeruoti komponentus), netlist failus ir patikrinti, ar nėra schemoje nėra klaidų (DRC). Tuo pačiu galima sugeneruoti ir BOM failus. Tada reikia įsitikinti, jog prie kiekvieno komponento yra priskirtas footprint.

Komponentų numeravimas (annotations)

KiCad leidžia automatiškai sunumeruoti visus komponentus. Tai galima rasti

Tools → Annotate Schematic… arba paspaudus mygtuką 2020 12 07 OeeTechWiki kiCad 21pav.png esantį viršuje.

2020 12 07 OeeTechWiki kiCad 22pav.png2020 12 07 OeeTechWiki kiCad 23pav.png

Dažniausiai galima naudoti numatytus numeravimo nustatymus, bet jei reikia, galima pakeisti pagal kokią ašį ir nuo kurio skaitmens bus numeruojami komponentai.

Netlist generavimas

Netlist galima sugeneruoti nuėjus į Tools → Generate Netlist File… arba paspaudus [[File:2020_12_07_OeeTechWiki_kiCad_24pav.png|32px].

2020 12 07 OeeTechWiki kiCad 25pav.png2020 12 07 OeeTechWiki kiCad 26pav.png2020 12 07 OeeTechWiki kiCad 27pav.png

Bill of Materials (BOM) generavimas

Prieš generuojant BOM, patartina patikrinti visų komponentų parametrus. Tai patogiausia atlikti nuėjus į Tools → Edit Symbol Fields… arba paspaudus 2020 12 07 OeeTechWiki kiCad 28pav.png. Šiame lange taip pat patogu priskirti footprintus.

2020 12 07 OeeTechWiki kiCad 29pav.png2020 12 07 OeeTechWiki kiCad 30pav.png

BOM failus galima sugeneruoti nuėjus į Tools → Generate Bill of Materials… arba paspaudus 2020 12 07 OeeTechWiki kiCad 31pav.png.

2020 12 07 OeeTechWiki kiCad 32pav.png2020 12 07 OeeTechWiki kiCad 33pav.png

Pasirinkus norimą skriptą ir sugeneravus BOM failą, jį galima rasti projekto aplankale. Šiuo atveju BOM failą galima atidaryti LibreOffice Calc programoje.

Schemos klaidų patikra (Electrical Rule Checker)

Galiausiai reikia patikrinti, ar schemoje nėra klaidų. Tam reikia atlikti klaidų patikrą (ERC), kuria galima rasti Inspect → Electrical Rule Checker arba paspaudus 2020 12 07 OeeTechWiki kiCad 34pav.png.

2020 12 07 OeeTechWiki kiCad 35pav.png2020 12 07 OeeTechWiki kiCad 36pav.png

Footprintų patikra

Prieš pereinant į PCB būtina įsitikinti, jog visi komponentai turi reikalingus footprint’us. Tai galima atlikti nuėjus į Tools → Assign Footprints… arba paspaudus 2020 12 07 OeeTechWiki kiCad 37pav.png.

2020 12 07 OeeTechWiki kiCad 38pav.png2020 12 07 OeeTechWiki kiCad 39pav.png

Galima pažymėti keletą komponentų ir jiems priskirti vieną footprintą. Tam atlikti reikia pažymėti pirmąjį komponentą paspaudus ant jo kairįjį pelės mygtuką ir laikant SHIFT paspausti ant paskutinio norimo pažymėti komponento. Kairėje pusėje reikiamo komponento tipą (pvz. Resistor_THT) reikia susirasti norimą footprint ir du kartus ant jo paspausti kairįjį pelės mygtuką. Taip bus priskirtas footprint’as. Galiausiai išsaugoti galima paspaudus OK arba Apply mygtukus.

Komponentų įkėlimas į PCB dizaino failą (F8)

Galiausiai, galima pereiti prie PCB dizaino. Norint sukelti komponentų footprint’us į PCB dizainą, reikia paspausti (F8) arba nueiti į Tools → Update PCB from Schematic… .

Tuomet atsidariusiame lange paspausti Update PCB, ir įsitikinus jog nėra klaidų ir jog visi footprint’ai buvo įkelti, paspausti Close.

2020 12 07 OeeTechWiki kiCad 41pav.png2020 12 07 OeeTechWiki kiCad 40pav.png


PCB dizaino pagrindai

PCB navigacija ir footprint’ų manipuliacija didžiąją dalimi veikia taip pat, kaip schemoje. Tačiau yra keletas funkcijų, kurios yra specifinės PCB dizainui.

PCB parametrų keitimas

Norint pakeisti PCB parametrus (pvz. sluoksnių kiekį, takelių dydžius), galima nueiti į File → Board Setup…

2020 12 07 OeeTechWiki kiCad 42pav.png2020 12 07 OeeTechWiki kiCad 43pav.png

Takelių dydžius, sluoksnius galima keisti viršuje esančioje funkcijų juostoje.

2020 12 07 OeeTechWiki kiCad 44pav.png

Footprint’o apvertimas į kitą plokštės pusę (F)

Norint perkelti footprint’ą į kitą plokštės pusę, galima ant footprint’o paspausti (F).

2020 12 07 OeeTechWiki kiCad 45pav.png2020 12 07 OeeTechWiki kiCad 59pav.png2020 12 07 OeeTechWiki kiCad 46pav.png

Footprintų sujungimas

Norimai susidėjus komponentus ant plokštės, reikia pravesti takelius ir sujungti komponentus. Tam yra naudojami takeliai (X), diferencinės poros (Alt+6) ir užpylimo zonos (filled zones).

Takelių vedimas (X) ir perėjimas į kitus sluoksnius takelio vedimo metu (V)

Norint pravesti takelius reikia paspausti (X) ir tuomet paspausti ant norimos PCB vietos, kur bus pradėtas vesti takelis. Norint pereiti į kitą sluoksnį takelio vedimo metu, galima paspausti (V) ir padėti viją. Tuomet galima pakeisti sluoksnį paspaudus vieną iš shortcut’ų.

2020 12 07 OeeTechWiki kiCad 47pav.png2020 12 07 OeeTechWiki kiCad 48pav.png2020 12 07 OeeTechWiki kiCad 49pav.png2020 12 07 OeeTechWiki kiCad 50pav.png

Perėjus su vija iš Top Layer, jei nebus pasirinktas kitas sluoksnis, KiCad automatiškai pereis į Bottom Layer. Iš visų kitų sluoksnių, perėjus su vija, nieko nepaspaudus, KiCad automatiškai pereis į Top Layer.

Diferencinės poros (Alt+6)

Norint pravesti diferencine porą, reikia paspausti (Alt+6) ir paspausti ant vieno iš pad’ų, kuris turi dif. porą.

PCB išpjovimas (Edge.Cuts) (CTRL+SHIFT+L)

Prieš darant užpildus, patartina nusistatyti PCB išpjovos plotą. Tam atlikti reikia pasirinkti Edge.Cuts sluoksnį ir pasirinkti 2020 12 07 OeeTechWiki kiCad 51pav.png esantį dešinėje funkcijų lentynoje arba (CTRL+SHIFT+L). Pjaustant PCB, patartina naudotis Set Origin Point funkcija (SPACE), kuri leidžia apačioje matyti delta koordinates nuo pasirinkto PCB taško. Laikant (CTRL) galima tiesiai nupiešti linijas.

2020 12 07 OeeTechWiki kiCad 52pav.png2020 12 07 OeeTechWiki kiCad 53pav.png

Užpylimo zonos (Filled Zones) (SHIFT+CTRL+Z)

Išpjovus PCB, galima daryti užpildą. Tam atlikti pirma reikia pasirinkti kokį nors vario sluoksnį (pvz. PgUp). Tuomet paspausti dešinėje pusės funkcijų lentynoje esantį 2020 12 07 OeeTechWiki kiCad 54pav.png mygtuką arba paspaudus (CTRL+SHIFT+Z) ir ant edge cut kampo (patartina šiek tiek labiau į plokštės vidų, dėl PCB gamybos procesų) paspausti kairįjį pelės mygtuką. Tuomet, atsidariusiame lange galima pasirinkti norimas linijas (Net), sluoksnį bei parametrus ir paspausti OK.

2020 12 07 OeeTechWiki kiCad 55pav.png

Tuomet reikia nubrėžti zoną, kurioje bus užpildas. Zonos braižymo principai yra analogiški išpjovos braižymo principams. Paspaudus (Alt+3) galima pažiūrėti 3D PCB vaizdą.

2020 12 07 OeeTechWiki kiCad 56pav.png2020 12 07 OeeTechWiki kiCad 57pav.png